Administrator user unable to view or create cases in the Customer Care Portal

Problem

You have a Legacy Enterprise Support role and are unable to view or create cases in the Customer Care Portal. You receive the error below when trying to view or create cases for the domain:
You are not authorized to list support cases.

Environment

  • Google Workspace for Education
  • Admin roles
  • Customer Care Portal

Solution

  1. If the administrator is older than 18 years old, move the user to an organizational unit where all users are 18 or older, this way the age restrictions will not be applied to the delegated user. For further information review the following articles:

Cause

Google Workspace for Education edition are subject to Age-based access settings and users in Organizational units where admins have indicated there are users younger than 18 years old are subject to restrictions in their accounts, within those restrictions the creation or visibility of support cases in the Customer Care Portal.