Cannot load iOS Apps device policy payload profile

Problem

Your new Mobile Device Management payload does not match the old payload. Mismatched keys: topic, serverURL, CheckinURL.

 

Environment

  • Mobile
  • iOS

Solution

To fix the problem, remove the old profile / other MDM app. The new profile will automatically reinstall when you try to access your work account on the device. Follow the steps described below:
  1. On your iOS device, tap Settings > General > VPN & Device Management
  2. Tap on the Payload app > Remove Management.

Cause

The new payload does not match the old payload.