Problem
When attempting to use the Samsung Smart Switch Mobile app, you get a message saying that the admin does not allow use of the app or that you need to contact IT.
Environment
- Android Device Management
- Device using a Google Workspace account as the main account
Solution
Samsung recommends to use the managed configurations as a possible work around (it might not always work). The steps on how to configure this are the following:
- Log in to the Admin console.
- Navigate to Apps > Web and mobile apps.
- Look for the Smart Switch app.
- Click Add app > Search for apps, look for Smart Switch app click Select, then complete the setup by selecting the OU and finish the process.
- Click on the app that should be listed now and then click Managed configurations.
- Select Add managed configuration.
- Turn on Allow SmartSwitch Run and save the changes.
Cause
The app has being built to be used on personal devices and is not compatible with managed devices, this is a limitation on the app itself.