Cannot restore email address linked to visitor account

Problem

You are unable to recover a recently deleted user attached to another account.

Environment

  • Google Workspace
  • Web UI
  • Visitor account

Solution

To Resolve:
  1. Go to the Admin Console
  2. Under Users > Add new user create a user with the name user@Domain 
  3. Change that user name as test.user@Domain. 
    • From Users > click the user's name.
    • Click Update user, you will be able to change the email address there.
  4. Delete the email alias automatically created. 
    • From User profile > User information > Select the email address> Click X > Save.
  5. Restore the account User@domain.
    • From the Admin console > Users > Add a filter > Recently deleted. 
    • Hover over the user and click Recover.
  6. Delete the user test.user@domain

Cause

There is a visitor account created with the same email address that the admin is trying to recover, this can not be found from the admin side.