Problem
When trying to sync iOS accounts, you get the following error message: Device policy alert. Google workspace access for your account has been disabled on this device. please contact your admin.
Environment
- iOS devices
- Advanced management turned on
- Apple Push certificate is setup and up to date
- Users are using the Google Device Policy app for setup
Solution
You must turn on iOS sync by following these steps:
- Go to Devices > Mobile and endpoints > Settings > Universal Settings.
- Locate the iOS sync policy on Data Access.
- Save the changes.
Cause
Issue is caused by the iOS sync being off.