Problem
When trying to upload a file to a shared drive owned by an external user, operation fails, even if you have the content manager role.
Environment
- Drive
- Shared drives
Solution
- In your Google Admin console.
- Go to Menu > Apps > Google Workspace > Drive and Docs.
- Click Sharing settings > Sharing options.
- Select the desired organizational unit or group.
- In Distributing content outside of your organization, select Anyone.
- Save the changes and try uploading the file again.
Cause
Organization has the Distributing content outside your organization set to No one, this will prevent internal users to upload files to external shared drives.