Changes are not saved when updating user's primary email

Problem

When trying to change a user's email address, the change appears to be successful, and it says Primary email updated, however, the changes are not applied to the user's email address and the original primary email address remains.

Environment

  • Admin console

Solution

Note: Email aliases should not exceed 30 in total.
  1. In the Admin console.
  2. Navigate to Main MenuDirectory > Users.
  3. Click the user's name to open the user settings page.
  4. Under the user's name, click Add Alternate Emails.
  5. Next to the email alias shown on the right side, click Remove X next to the one you want to delete.
  6. Click Save.
Once the alias is removed, you can attempt to change the user's primary email address again and the changes should be applied successfully, leaving the old email as a new email alias. You may refer to this Help Center article for more details about adding or deleting email aliases.

Cause

This is an expected behavior whenever the email alias limit of 30 has been reached for the user. When a user's primary email address is updated, the old one becomes an email alias automatically, however, if there is no more room for email aliases, the change in the email alias is not applied.