Problem
Unable to re-enroll the device due to the serial number being recognized as a new device and there are no available licenses which will prompt an error about not having them when attempting to re-enroll.
Environment
- Managed ChromeOS devices
- Admin console
Solution
- You have to make sure the original SN is deprovisioned as Same model replacement, to confirm this:
- Log in to the Admin console.
- Navigate to Devices > Chrome > Devices.
- Here, click on Status at the top and select All.
- Now on the Chromebook, go to the sign in screen and hit Alt + V, the serial number will be displayed at the top of the screen.
- In the Admin console, search with that serial number using the option Search or add a filter at the top.
- If no results are shown, it means the serial number was changed.
- Now search with the serial number you had before sending it to repairs.
- Select the device and look for the field Deprovision reason.
- If this field has a value other than Same model replacement, the license was no longer available and you need to request its release on the backend.
Cause
- Replacing the motherboard gave the device a new serial number.
- The correct serial number was not assigned.