Chromebooks show as non-compliant in their version

Problem

You notice that some ChromeOS devices show as having a non compliant version on the Admin console. 

Environment

  • Managed Chromebooks
  • Devices list
  • Admin Console

Solution

You must make sure that as the device is updated and has time to sync the information to the Admin console, as described below:
  1. Go to the Admin console
  2. On the menu at the left go to Devices > Chrome > Devices.
  3. Click on the device you want to check.
  4. Look for Hardware and OS > OS version policy compliance.
You might notice that some devices show compliant while others don't, the reason is because the Channel version field (which is the latest available version for that device in the stable channel) in that same section, does not match the ChromeOS version field (which is the version the device currently has).

This means that the device is behind updates (has an older version) and this could be due to one for the following reasons:
  • The device hasn't been updated for some reason: This could be due to network connectivity issues, as well as due to some policies (such as pinning to a specific ChromeOS version).
  • The device has no connection to report the actual device status.

Cause

This happens when the ChromeOS device has a version that is older than the latest one available for that model.