ChromeOS prompts for old password after password reset

Problem

Users are being asked to enter their old password when trying to log in to ChromeOS but password has been reset recently.

Environment

  • ChromeOS

Solution

  1. Users must enter the old password when there is an existing profile on ChromeOS, if users do not need any information already saved in the existing profile, the profile can be removed from the Admin console or wipe the device itself.

Cause

  • The user has changed the password on a device different from the Chromebook in use.
  • Profile data is being encrypted and users must have their old password to access the old profile.