Problem
Files within Google Drive for Desktop show the incorrect modification date, even after making changes on the document.
Environment
- Google Drive for desktop
- Windows or Mac
Solution
- Add Google Drive for desktop in the anti-virus/malware allow list so the software understands that Drive for desktop does not need to be scanned.
- Clear Google Drive for desktop cache:
- Windows computer:
- Quit Google Drive by clicking the icon in your taskbar, then the gear icon
- Click Quit or Exit.
- Note: Make sure there are no uploads in progress before doing this step.
- Open your file explorer and go to your C://Users/YourUser.
- Replace YourUser with your username.
- Go to the top of the file explorer, click View, and select Hidden item.
- Open the hidden folder Apps data > Local > Google.
- Move the folder DriveFS to your desktop.
- Relaunch the app and sign in as normal.
- At this point, you can uninstall and reinstall the app if you prefer.
- Mac:
- Quit Google Drive by clicking the icon in your taskbar, then the gear icon and then click Quit or Exit.
- Note: make sure there are no uploads in progress before doing this step.
- Open Finder.
- Press Command+Shift+G.
- Enter ~/Library/Application Support/Google/.
- Find a folder named 'DriveFS' and move it to your desktop.
- Relaunch the app and sign in as normal. At this point, you can uninstall and reinstall the app if you would rather.
- Quit Google Drive by clicking the icon in your taskbar, then the gear icon and then click Quit or Exit.
- Windows computer:
Cause
Third party app scanning files, most of the time a antivirus or malware.