Problem
Emails between 2 users of the organization are getting classified as spam.
Environment
- Gmail
- IMAP
Solution
You must check and remove third party account access.
- Access My Google account.
- Go to Security > Third-party apps with account access.
- Check all the apps connected to the account.
- Revoke the access to any unknown, or not necessary apps.
Cause
Third party app or email client with IMAP connection is moving the emails automatically.