Internal emails are being marked as spam

Problem

Emails between 2 users of the organization are getting classified as spam.

Environment

  • Gmail
  • IMAP

Solution

You must check and remove third party account access.
  1. Access My Google account.
  2. Go to Security > Third-party apps with account access.
  3. Check all the apps connected to the account.
  4. Revoke the access to any unknown, or not necessary apps.

Cause

Third party app or email client with IMAP connection is moving the emails automatically.