Emails sent to user A are forwarded to user B

Problem

You want to find out why an email is sent to user A, it is delivered to user B instead.

Environment

  • Gmail

Solution

  1. Send a test email to user A.
  2. Get the message ID by following these steps:
    • Go to Gmail and open the message.
    • On the right side of the screen, click the three dots icon next to Reply icon, then click Show Original.
    • Locate and copy the message ID.
  3. In your Admin console, go to Reporting > Email Log Search.
  4. Paste the Message ID and click Search.
  5. Click the message ID under the Results.
  6. Click the recipient's email address under Recipient details.
  7. The triggered routing rule will be noted under the delivery details.
  8. Disable the rule by going to Apps > Google Workspace > Gmail and then select the section where the rule was set: Default Routing, Compliance, or Routing
  9. Locate the triggered rule and click Disable or Delete.
 
 

Cause

Routing rule changing the original recipient.