"Error 403, "Not Authorized to access this resource/api", forbidden" message when trying to update a password for a user

Problem

When trying to update a password for a user the following error is seen in the logs for the service:

"error": {
"code": 403,
"message": "Not Authorized to access this resource/api",
"errors": [
{
"message": "Not Authorized to access this resource/api",
"domain": "global",
"reason": "forbidden"

Environment

  • Password Sync

Solution

  1. Verify if the primary email address on your Active Directory for the reported users is failing to sync their passwords matches with the primary email address in Workspace.

Cause

If the email addresses in the mail attribute does not match the email addresses on Workspace, then the Password Sync would attempt to set a password for a user that doesn't exist in your account, and therefore, you wouldn't have access to modify this user (whether it exists or not) hence why Not Authorized to access this resource/api error.