Error changing access for users in a Shared drive

Problem

Trying to change the user's access level on a shared drive and the next error is displayed:
The user is not licensed to have higher than viewer access.

Environment

  • Google Drive

Solution

  1. Log in to the Admin console.
  2. Navigate to the Directory > Users > Search for the user and click on its name > Click on the Licenses tab.
  3. Make sure it is a Shared drive compatible Google Workspace edition.
    • Google Workspace Business Standard or higher editions.
  4. Click on the current Google Workspace edition.
  5. Assign the compatible license.
  6. Save the changes.

Cause

If you have a Google Workspace account with multiple Google Workspace licenses (Partial domain licenses), Users under Google Workspace Business Starter can only have Viewer permission on shared drives created by users with a Business Standard edition in your account.