Error message trying to add an account on mobile device

Problem

You are unable to add an account on Mobile Devices (Android/iOS) due to the following error message:
We detected an unusual sign-in attempt. To make sure that someone else isn't trying to access your account, your organization needs you to sign in using your corporate mobile device (the phone or tablet you normally used to access your corporate account).

If you don't have your corporate mobile device with you right now, try again later when you have your corporate mobile device with you. If you continue to have problems signing in, contact your administrator.

Environment

  • Admin console
  • Login challenge without corporate mobile device

Solution

  1. Disable login challenge temporarily as an administrator.
  2. Log in to the Admin console.
  3. Go to Users.
  4. Within the user's list, find the user.
  5. Click the user's name to open their account page.
  6. Click Security > Login Challenge and then Turn off for 10 mins.
  7. Click Save.
  8. Within 10 mins, have your user login and add a device to their account.

Cause

Login challenge is enabled, but users have not added a phone number to their account, so they are unable to complete the sign-in process.