Error message when trying to update a password user

Problem

When trying to update a password for a user, you see the following error in the logs for the service:
"error": {
"code": 403,
"message": "Not Authorized to access this resource/api",
"errors": [
{
"message": "Not Authorized to access this resource/api",
"domain": "global",
"reason": "forbidden"

Environment

  • Password Sync

Solution

  1. Verify if the primary email address on your Active Directory for the reported users is failing to sync their passwords, and if matches with the primary email address in Workspace.

Cause

If the email addresses in the mail attribute does not match the email addresses on Workspace, then the Password Sync would attempt to set a password for a user that does not exist in your account, and therefore, you would not have access to modify this user (whether it exists or not) hence why Not Authorized to access this resource/api error.