Thông báo lỗi khi cố gắng cập nhật mật khẩu của người dùng

Vấn đề

Khi cố gắng cập nhật mật khẩu cho người dùng, bạn sẽ thấy lỗi sau trong nhật ký cho dịch vụ:
"error": {
"code": 403,
"message": "Not Authorized to access this resource/api",
"errors": [
{
"message": "Not Authorized to access this resource/api",
"domain": "global",
"reason": "forbidden"

Môi trường

  • Đồng bộ hoá mật khẩu

Giải pháp

  1. Xác minh xem địa chỉ email chính trên Active Directory của người dùng bị báo cáo có không đồng bộ hoá mật khẩu của họ và địa chỉ đó có khớp với địa chỉ email chính trong Workspace hay không.

Nguyên nhân

Nếu địa chỉ email trong thuộc tính mail không khớp với địa chỉ email trên Workspace, thì tính năng Đồng bộ hoá mật khẩu sẽ tìm cách đặt mật khẩu cho người dùng không có trong tài khoản của bạn. Do đó, bạn sẽ không có quyền sửa đổi người dùng này (cho dù có tồn tại hay không). Do đó, lỗi Không được phép truy cập vào tài nguyên/api này.