Problem
You are getting the following error while trying to access your Google Voice account:
Address couldn't be verified. Correct it, provide another address, or contact your Google Workspace administrator.
Environment
- Google Voice web
Solution
- In the Admin console.
- Go to Menu > Apps > Google Workspace > Google Voice.
- Click Users.
- On the Users page, you can review the details of each user that has a Voice license.
- At the top of the page, click Filters and then Address Registration Status.
- Click Failed and then Apply to review a list of all users with failed address registrations.
- If needed, you can update user addresses.
To update user address individually
- In the Admin console.
- Go to Menu > Apps > Google Workspace > Google Voice.
- Click Users.
- On the Users page, you can review details for each user that has an assigned Voice license.
- Point to the user and click Edit number.
- Click Unassign.
- To confirm, click Unassign.
- Point to the same user and click Assign number.
- In the Country/region field, click the Down arrow and select a country/region from the list. If you select a location that isn't one of your Voice locations, you get an error message.
- In the Service address field, enter the complete address of the user's location. This address needs to be correct for emergency services.
- Google Voice verifies each service address. If you get an error message, go to Change service addresses.
- Click Assign.
Cause
Every user needs a service address for their location. The service address must be entered correctly for emergency services. As an admin, you can add, update, or correct the address for your users.