Error sending emails to a newly created account

Problem

You create a new user account, inside a new domain, send a test email to the newly created user, but a bounce back message is received:
Your message wasn't delivered because the address couldn't be found, or is unable to receive mail

Environment

  • Gmail Delivery
  • Admin Console

Solution

  1. Confirm the domain's MX Records are configured using the Dig tool.
    • To see the correct MX Records for Google Workspace check this article.

Cause

Google MX records are missing on the domain which are capable of receiving emails on the domain.