Error "Trouble submitting template, please try again"
Stay organized with collections
Save and categorize content based on your preferences.
Problem
You receive the following error message when submitting a new template.
Trouble submitting template, please try again.
Environment
Solution
- Sign in to the Admin console.
- Navigate to Apps > Google Workspace > Drive and Docs > Templates.
- Confirm Template Gallery submission settings is set to Open by going to
- Check in the Admin audit logs if the setting was recently changed.
- Confirm if the file is under My Drive.
- Confirm if the file used to create the template is in a shared drive, this may cause issues due to access levels/ file ownership and authorization.
- If yes, make a copy and add it under My Drive, this should fix the issue.
Cause
File ownership.
Except as otherwise noted, the content of this page is licensed under the Creative Commons Attribution 4.0 License, and code samples are licensed under the Apache 2.0 License. For details, see the Google Developers Site Policies. Java is a registered trademark of Oracle and/or its affiliates.
Last updated 2023-10-11 UTC.
[{
"type": "thumb-down",
"id": "missingTheInformationINeed",
"label":"Missing the information I need"
},{
"type": "thumb-down",
"id": "tooComplicatedTooManySteps",
"label":"Too complicated / too many steps"
},{
"type": "thumb-down",
"id": "outOfDate",
"label":"Out of date"
},{
"type": "thumb-down",
"id": "samplesCodeIssue",
"label":"Samples / code issue"
},{
"type": "thumb-down",
"id": "otherDown",
"label":"Other"
}]
[{
"type": "thumb-up",
"id": "easyToUnderstand",
"label":"Easy to understand"
},{
"type": "thumb-up",
"id": "solvedMyProblem",
"label":"Solved my problem"
},{
"type": "thumb-up",
"id": "otherUp",
"label":"Other"
}]