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Problem
Events reappearing after being deleted.
Environment
Google Calendar
Solution
Check the Drive log events for third party interactions with Google Calendar permissions.
Go to the Admin console > Reporting > Audit an investigation > Calendar log events > Add filter > Event title > Drop down menu > Contains.
Type the Event name and click Search.
Locate the column called Event, there the Event created action appears.
Click on the description > API kind and User agent
Cause
Third party applications were interacting with the Google Calendar service, and it is highly probable they were recreating the events after being deleted
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