問題
組織内のすべてのユーザーを含むグループ宛てのメールを受信しないように特定のユーザーを除外します。
環境
- 管理コンソール
解決策
- 管理コンソール。
- [アプリ] > [Google Workspace] > [Gmail] > [コンプライアンス] に移動します。
- [コンテンツ コンプライアンス] 設定に移動し、[ルールを追加] をクリックします。
- グループに届くすべてのメッセージを対象とするには、[受信] と [内部 - 受信] オプションを選択します。
- [各メッセージで検索するコンテンツを表す表現を追加する] で、次のいずれかを選択します。
- 以下のすべてがメールに一致する場合:
- [表現] の横にある [追加] ボタンをクリックします。
- 式を次のように設定します。
- [シンプルなコンテンツ マッチ] を [高度なコンテンツ マッチ] に変更します。
- [Location] フィールドで、[Full headers] を選択します。
- [マッチタイプ] で [テキストを含む] を選択します。
- [Content] フィールドに「X-Been There: group@domain.com」と入力します。アドレスは、目的のグループのアドレスに置き換えます。
- [保存] ボタンをクリックします。
- [追加] ボタンをもう一度クリックして、別の式を追加します。
- 式を次のように設定します。
- [高度なコンテンツ マッチ] を選択します。
- [場所] フィールドで [完全なヘッダー] を選択します。
- [マッチタイプ] で [テキストを含む] を選択します。
- [コンテンツ] に、[組織の全ユーザー] グループから除外するユーザーのメールアドレスを入力します。
- [保存] ボタンをクリックします。
- 最後に、これらの表現を追加した後、送信者の NDR を生成しない場合は、3 番目の [上記の表現が一致する場合、次の処理を行う] の [メッセージを変更] を [メールを拒否] または [検疫] に変更します。
- [保存] ボタンをクリックします。
原因
このようなグループでは、「組織内のすべてのユーザー」という特別なユーザーとして、すべてのドメイン ユーザーが自動的にこれらのグループに追加されます。ただし、必ずしもこのグループにメッセージを配信したいのは必ずしもすべてのユーザーであるとは限りません。コンテンツ コンプライアンス ルールを設定することが、配信を避ける最善の方法となります。