External emails bounced back stating the domain expired
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Problem
Emails sent by external senders are getting bounced back saying that the email address do not exist.
Environment
- Domain registration
- Admin console
- Google Workspace setup
- Gmail
Solution
- Access your DNS hosting provider.
- Access the DNS settings, and renew your domain registration.
- Make sure the MX (Mail exchanger servers) records are not missing.
- If they are missing proceed to add them as per this article.
- Allow 24 to 48 hours of propagation to test changes.
Cause
The domain expired and was not set to renew.
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Last updated 2023-10-02 UTC.
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