External emails rejected due to expired domain

Problem

Emails sent by external senders are getting bounced back saying that the email address do not exist.

Environment

  • Domain registration
  • Admin console
  • Google Workspace setup
  • Gmail

Solution

  1. Access your DNS hosting provider.
  2. Access the DNS settings, and renew your domain registration.
  3. Make sure the MX (Mail exchanger servers) records are not missing.
  4. If they are missing proceed to add them as per this article.
  5. Allow 24 to 48 hours of propagation to test changes.

Cause

The domain expired and was not set to renew.