Problem
External users are unable to send emails to a group as the emails are getting bounced with the message: The account sender@domain.com is disabled.
Environment
- Groups
- Groups Delivery
Solution
You must submit a request to restore the account following these steps:
- Sign in to your Google Account on a browser, e.g. Chrome.
- Select Start Appeal.
- Follow the instructions.
- Go to the Data & Privacy section of your Google Account (myaccount.google.com).
- Scroll to Your data & privacy options.
- Select More options, and then Delete your Google Account.
- Follow the instructions to delete your account.
Cause
The consumer account for the sender was previously under Google Workspace and is currently disabled even when currently is being used with a third party service provider.
- Group rejecting emails from external sender
- Sender is not a Goorgle Workspace user currently.
- Sender was previously a Goorgle Workspace user and was disabled.