Factory Reset Protection asking for old email

Problem

When you factory reset a device and try to register a user, the device is asking for an old account registered on which the user has been removed in the Admin Console.

Environment

  • Mobile Device Management
  • Android

Solution

  1. Check if the Factory Reset Protection is configured.
  2. Log in to the Admin console.
  3. Navigate to Devices > Mobile and endpoints > Android settings > Device Features > Factory reset protection.
  4. You should use the email added to the Factory Reset Protection to bypass the old email that the device is asking to recover.

Cause

This occurs since the old email was previously deleted in the Admin console and cannot be used to recover the device.