Factory reset protection triggered after factory reset

Problem

You are unable to use the device after factory reset since you need the previous account.

Environment

  • Android Device Management

Solution

The way you set the Factory Reset Protection policy, is the following:
  1. On the Admin console, go to Devices > Mobile and endpoints > Settings > Android Settings.
  2. Once there, you will find the policy under Device Features.
  3. There, you must add the list of administrators you want to use in scenarios like this. 
  4. If this wasn't set, you will need to reach the manufacturer to request the protection lock to be removed. 
​ ​ ​ ​ ​ ​ ​ Note: The Factory Reset Protection policy would the only way to avoid the devices being locked when the account that was on the device is not longer available. Please note that this policy must have been set up before the factory reset and the device should have been able to sync the policy.

Cause

Because the factory reset protection is a feature built within Android itself and is not controlled by the Admin console.