How to add a managed account to Android TV

Problem

Trying to add the account to an Android tv but it won't allow to sync due to MDM policies. 

Environment

  • Mobile Device Management
  • Android Device Management

Solution

Disable the mobile device management so the system won't enforce policies on the TV by following the steps listed below:
  1. Go the Admin console and from the left menu select Devices > Mobile and endpoints > Settings > Universal Settings.
  2. Click on General at the top.
  3. Click on Mobile management.
  4. Select the option to disable the mobile management please. 
  5. Save the changes.

Cause

Issue is caused because Google Workspace mobile device management detects the Android smart TV as a smartphone and tries to manage it the same way.