Problem
You are not able to connect to any WiFi network outside your organization.
Environment
- ChromeOS
- Chromebooks
Solution
IMPORTANT: Make sure that there is no restriction for the network connection by following the steps described below.
- Log in to the Admin console.
- Go to Devices > Network.
- Choose the organizational unit where the users are.
- Go to General settings.
- For Auto-connect remove the restriction, then Save.
- For WiFi networks remove the restriction, then Save.
- Make sure that the Chromebooks are connected to the assigned WiFi while the policies are being pushed, so they can connect to a different network.
- Check that the configuration reached the device:
- Open chrome://policy
- Search for the policy DeviceOpenNetworkConfiguration and review the following:
- DisableNetworkTypes is not present.
- AllowOnlyPolicyNetworksToAutoconnect is false.
Cause
The root cause are the policies that only allow the device to connect to specific configured WiFi.