Problem
Bei dem Versuch, in Google Cloud Directory Sync zu synchronisieren, erhalten Sie die folgende Fehlermeldung:
'400 Bad Request { "error" : "invalid_grant", "error_description" : "Token has been expired or revoked." }'
Umgebung
- Google Cloud Directory Sync
Lösung
Sie müssen Ihr Google-Konto für die Authentifizierung autorisieren. Gehen Sie dazu so vor:
- Öffnen Sie den Konfigurationsmanager und klicken Sie auf Konfiguration der Google-Domain.
- Klicken Sie auf Jetzt autorisieren > Anmelden.
- Melden Sie sich in Ihrem Google-Konto als Super Admin an.
- Klicken Sie auf Zulassen.
- Der Konfigurationsmanager empfängt den Bestätigungscode und autorisiert GCDS.
- Schließen Sie das Browserfenster.
Wenn Sie einen Computer ohne GUI verwenden, lesen Sie den Hilfeartikel Wie autorisiere ich GCDS auf einem Computer ohne GUI?
Optionaler Schritt: Widerrufen Sie das Zugriffstoken.
Wenn Sie alte Anmeldedaten verwenden möchten, können Sie das Zugriffstoken widerrufen und noch einmal autorisieren:
- Sie müssen mit dem Super Admin-Konto angemeldet sein, das zur Autorisierung von GCDS verwendet wurde.
- Gehen Sie zu Apps mit Zugriff auf mein Konto.
- Klicken Sie unter Google-Apps auf Google Cloud Directory Sync.
- Klicken Sie auf Zugriffsrechte entfernen.
- Autorisieren Sie Ihr Konto noch einmal, indem Sie die oben genannten Schritte ausführen.
Weitere Informationen finden Sie im Hilfeartikel Google-Konto autorisieren.
Ursache
Sie erhalten den Fehler 400 Bad Request und möchten den Fehler beheben.