So autorisieren Sie Ihr Google-Konto

Problem

Bei dem Versuch, in Google Cloud Directory Sync zu synchronisieren, erhalten Sie die folgende Fehlermeldung:
 '400 Bad Request { "error" : "invalid_grant", "error_description" : "Token has been expired or revoked." }' 

Umgebung

  • Google Cloud Directory Sync

Lösung

Sie müssen Ihr Google-Konto für die Authentifizierung autorisieren. Gehen Sie dazu so vor:

  1. Öffnen Sie den Konfigurationsmanager und klicken Sie auf Konfiguration der Google-Domain.
  2. Klicken Sie auf Jetzt autorisieren > Anmelden.
  3. Melden Sie sich in Ihrem Google-Konto als Super Admin an.
  4. Klicken Sie auf Zulassen.
  5. Der Konfigurationsmanager empfängt den Bestätigungscode und autorisiert GCDS.
  6. Schließen Sie das Browserfenster.

Wenn Sie einen Computer ohne GUI verwenden, lesen Sie den Hilfeartikel Wie autorisiere ich GCDS auf einem Computer ohne GUI?

Optionaler Schritt: Widerrufen Sie das Zugriffstoken.

Wenn Sie alte Anmeldedaten verwenden möchten, können Sie das Zugriffstoken widerrufen und noch einmal autorisieren:

  1. Sie müssen mit dem Super Admin-Konto angemeldet sein, das zur Autorisierung von GCDS verwendet wurde.
  2. Gehen Sie zu Apps mit Zugriff auf mein Konto.
  3. Klicken Sie unter Google-Apps auf Google Cloud Directory Sync.
  4. Klicken Sie auf Zugriffsrechte entfernen.
  5. Autorisieren Sie Ihr Konto noch einmal, indem Sie die oben genannten Schritte ausführen.

Weitere Informationen finden Sie im Hilfeartikel Google-Konto autorisieren.

Ursache

Sie erhalten den Fehler 400 Bad Request und möchten den Fehler beheben.