Autoriser votre compte Google

Problème

Lorsque vous essayez de synchroniser dans Google Cloud Directory Sync, vous recevez le message d'erreur suivant:
 '400 Bad Request { "error" : "invalid_grant", "error_description" : "Token has been expired or revoked." }' 

Environnement

  • Google Cloud Directory Sync

Solution

Vous devez autoriser votre compte Google à autoriser l'authentification en procédant comme suit:

  1. Ouvrez le gestionnaire de configuration et cliquez sur Google Domain Configuration (Configuration du domaine Google).
  2. Cliquez sur Autoriser maintenant > Connectez-vous.
  3. Connectez-vous à votre compte Google en tant que super-administrateur.
  4. Cliquez sur Autoriser.
  5. Le gestionnaire de configuration reçoit le code de validation et autorise GCDS.
  6. Fermez la fenêtre du navigateur.

Si vous utilisez une machine dépourvue d'IUG, consultez Comment autoriser GCDS sur un ordinateur sans IUG ?

Étape facultative: Révoquer le jeton d'accès

Si vous ne souhaitez pas utiliser d'identifiants de longue date, vous pouvez révoquer le jeton d'accès et renouveler l'autorisation:

  1. Vérifiez que vous êtes connecté avec le compte super-administrateur utilisé pour autoriser GCDS.
  2. Accédez à Applications ayant accès à votre compte.
  3. Sous Applications Google, cliquez sur Google Cloud Directory Sync.
  4. Cliquez sur Supprimer l'accès.
  5. Autorisez à nouveau votre compte en suivant les étapes ci-dessus.

Pour en savoir plus, consultez Autoriser votre compte Google.

Cause

Vous recevez l'erreur 400 (Requête incorrecte) et vous voulez le résoudre.