Problème
Lorsque vous essayez de synchroniser dans Google Cloud Directory Sync, vous recevez le message d'erreur suivant:
'400 Bad Request { "error" : "invalid_grant", "error_description" : "Token has been expired or revoked." }'
Environnement
- Google Cloud Directory Sync
Solution
Vous devez autoriser votre compte Google à autoriser l'authentification en procédant comme suit:
- Ouvrez le gestionnaire de configuration et cliquez sur Google Domain Configuration (Configuration du domaine Google).
- Cliquez sur Autoriser maintenant > Connectez-vous.
- Connectez-vous à votre compte Google en tant que super-administrateur.
- Cliquez sur Autoriser.
- Le gestionnaire de configuration reçoit le code de validation et autorise GCDS.
- Fermez la fenêtre du navigateur.
Si vous utilisez une machine dépourvue d'IUG, consultez Comment autoriser GCDS sur un ordinateur sans IUG ?
Étape facultative: Révoquer le jeton d'accès
Si vous ne souhaitez pas utiliser d'identifiants de longue date, vous pouvez révoquer le jeton d'accès et renouveler l'autorisation:
- Vérifiez que vous êtes connecté avec le compte super-administrateur utilisé pour autoriser GCDS.
- Accédez à Applications ayant accès à votre compte.
- Sous Applications Google, cliquez sur Google Cloud Directory Sync.
- Cliquez sur Supprimer l'accès.
- Autorisez à nouveau votre compte en suivant les étapes ci-dessus.
Pour en savoir plus, consultez Autoriser votre compte Google.
Cause
Vous recevez l'erreur 400 (Requête incorrecte) et vous voulez le résoudre.