Problem
Podczas próby synchronizacji w Google Cloud Directory Sync pojawia się ten komunikat o błędzie:
'400 Bad Request { "error" : "invalid_grant", "error_description" : "Token has been expired or revoked." }'
Środowisko
- Google Cloud Directory Sync
Rozwiązanie
Musisz autoryzować swoje konto Google do zezwalania na uwierzytelnianie, wykonując te czynności:
- Otwórz menedżera konfiguracji i kliknij Google Domains Configuration (Konfiguracja domeny Google).
- Kliknij Autoryzuj teraz > Zaloguj się.
- Zaloguj się na swoje konto Google jako superadministrator.
- Kliknij Zezwól.
- Menedżer konfiguracji odbiera kod weryfikacyjny i autoryzuje GCDS.
- Zamknij okno przeglądarki.
Jeśli używasz komputera bez GUI, przejdź do artykułu Jak autoryzować GCDS na komputerze bez GUI?
Krok opcjonalny: unieważnij token dostępu.
Jeśli nie chcesz używać tych danych przez dłuższy czas, możesz unieważnić token dostępu i ponownie przeprowadzić autoryzację:
- Zaloguj się na konto superadministratora, które zostało użyte do autoryzacji GCDS.
- Otwórz Aplikacje, które mają dostęp do Twojego konta.
- W sekcji Aplikacje Google kliknij Google Cloud Directory Sync.
- Kliknij Usuń dostęp.
- Ponownie autoryzuj konto, wykonując czynności opisane powyżej.
Jeśli potrzebujesz więcej informacji, zapoznaj się z artykułem Autoryzacja konta Google.
Przyczyna
Wyświetla się błąd 400 Nieprawidłowe żądanie i chcesz go naprawić.