How to change primary domain

Problem

The customer does not have all details clear in order to change the primary domain and implications for users. 

Environment

  • Customer with a secondary domain not verified
  • Gmail not activated

Solution

  1. Sign in to the Admin console.
  2. Click on Account, then click on Domains and after that on Manage domains.
  3. Click on Add a domain and select Secondary domain.
  4. Add the domain's name there and start verification.
  5. After you add a secondary domain, make sure you verify the domain and activate Gmail or set up MX records in your domain host. 
  6. Once the domain is all set, click on Change primary domain and follow the steps to complete the process. 
  7. Now that the primary domain was changed, you can rename or update your users one by one in the Admin console or use Bulk update users option in Users.

Cause

The customer is in transition to a new brand and has not checked all the steps to complete the change.