How to clear Drive for desktop cache

Problem

How can you clear Drive for desktop cache to troubleshoot issues syncing or just release space in the computer.

Environment

  • Drive for desktop
  • Windows
  • Mac

Solution

Windows:
  1. Quit Drive for desktop by clicking the icon in your taskbar, then the gear icon and then select Quit or Exit.
    • Note: make sure there are no uploads in progress before doing this step.
  2. Open your file explorer and go to your C: drive.
  3. There, open the User folder. (Avoid opening the Default or Public user folder)
  4. Go to the top of the file explorer, click View, check mark Hidden item, open the hidden folder Appsdata.
  5. Open Local > Google.
  6. You will find a folder named DriveFS, move the folder to your desktop.
  7. Relaunch the app and sign in as normal. (At this point, you can uninstall and reinstall the app if you would rather). 
Mac:
  1. Quit Drive for desktop by clicking the icon in your taskbar, then the gear icon and then click Quit or Exit.
    • Note: make sure there are no uploads in progress before doing this step.
  2. Open Finder.
  3. Press Command+Shift+G.
  4. Enter ~/Library/Application Support/Google/
  5. You will find a folder named DriveFS, move the folder to your desktop.
  6. Relaunch the app and sign in as normal. (At this point, you can uninstall and reinstall the app if you would rather). 
Note: Once you made sure that all content is intact and issue is fixed, you can delete the DriveFS folder moved to the desktop. 

Cause

Clear cache in Drive for desktop