How to get a report for messages flagged as spam by users

Problem

How can you get a report in the Admin console when users manually open an email and mark it as spam.

Environment

  • Gmail
  • Admin console

Solution

In order to get a report in the Admin console you can use the investigation tool to retrieve messages flagged as spam by the user. Please follow the steps described below:
  1. Go to the Google Workspace Admin console.
  2. Hover your mouse on the left, then click Security > Security centre > Investigation tool.
  3. Under Data source choose Gmail log events.
  4. Under Attribute, click Add condition and choose Spam classification, in the third column after Is choose Spam.
  5. One more time, under Attribute click Add condition choose Event, in the third column after Is choose User spam classification.
  6. Click Search all messages manually flagged as spam by users will show in the report, which you can export if needed by clicking Export all.
Note: To use the investigation tool you need to have either Enterprise plus (recommended) or Enterprise Standard, please review Compare Enterprise editions to get further information.
 

Cause

Generate spam report, investigation tool needed.