How to manage quarantined messages

Problem

Inbound emails to your organization are in the Admin quarantine but you don't know how to remove them from it.

Environment

  • Admin console

Solution

 After setting up and configuring policies for a quarantine, you can view and manage messages in it.

To open the admin quarantine:

  1. Sign in to the Admin console.
  2. Navigate to Apps Google Workspace Gmail Manage quarantines
  3. Click Go to admin quarantine to display all the quarantines. 

Cause

You need to allow or reject the messages stored in the admin quarantine.