How to re-enroll Google Meet Hardware

Problem

Your device was deprovisioned and needs to be re-enrolled to your domain.

Environment

  • Google Meet devices

Solution

Before you can re-enroll a device, you need to wipe it.

Deprovision and set a device to pending

  1. In your Admin console.
  2. Go to Devices > Google Meet hardware > Devices.
  3. Choose an option:
    • To filter the devices by organizational unit or other criteria, see Choose devices by organizational unit.
    • To select one or more devices from the list, check the box next to each device.
  4. At the top left, click Deprovision.
  5. Confirm that you want to deprovision the device.
  6. Before you re-enroll a deprovisioned device, make sure the device is in Pending state.
    • In your Admin console.
    • Devices > Google Meet hardware > Devices.
    • If the device is in deprovisioned state, select the device and then click Set to Pending.
    • Confirm your device is in Pending state.

Re-enroll Google Meet hardware

To re-enroll a Chromebox or Chromebase or Google Meet hardware:
  1. Turn on your device.
  2. Attach a keyboard to the device.
  3. Using the Meet Compute System Recovery Utility, remove and reinstall the Chrome operating system for use with Google Meet.
  4. Complete the steps to enroll a device.

Cause

The device was deprovisioned.