Problem
How can you request a refund for an account that was already upgraded to Google Workspace for Nonprofits free edition, but there are charges already in the account for all the time the account had been on a Google Workspace paid subscription?
Environment
- Admin console
- Google Workspace for Non Profits
Solution
The upgrade to Google Workspace for Nonprofits is not retroactive, and the free service applies from the moment the Google for Nonprofits team upgrades your account to the free edition of Google Workspace for Nonprofits after you submit the activation request.
Note: If your account was not on a paid edition when you started the application process, but you had to start paying after the trial period while waiting for the application to be processed, please contact Google Workspace support.
Note: If your account was not on a paid edition when you started the application process, but you had to start paying after the trial period while waiting for the application to be processed, please contact Google Workspace support.
Cause
The Google Workspace account was already on a paid edition, and then the organization decided to apply to get the Google Workspace for Nonprofits free edition.