How to stop receiving emails twice

Problem

You notice that every incoming mail is received twice.

Environment

  • Gmail Delivery
  • Routing

Solution


There were 2 rules created, a default routing and a regular routing rule acting as a catch-all, you must remove or disable one of the rules.

Cause

The organization has emails hosted in a third party web mail provider and the emails were being received twice in that server, messages were forwarded due to a split delivery.