Problem
You notice that an email found in the inbox of a user does not come up in Email Log Search.
Environment
- Gmail Delivery
- Email log search
Solution
- The email is found in the inbox of one user, open the email.
- Click on the 3 dots button all the way to the right of the date and time, next to the star and reply buttons.
- Click Show original, a new tab will be opened, that is the message header.
- Copy the message ID, the green colored string of characters at the top.
- Go to the Admin console homepage.
- On the left side menu, click Reporting > Email log search.
- Specify the date in which the email was received and paste the message ID in the respective field, and click Search.
Cause
Sometimes the email may not be found by searching with the sender's email address as a search criteria since some automated emails might show an email address to the end recipient's inbox while the Email Log Search is provided with a different email address, causing the email not to be easily found.