How to validate MX Records

Problem

How can you validate your mail exchange (MX) Records are correct when you are not receiving emails?

Environment

  • Gmail configured for company's email messages

Solution

  1. Use the Dig tool's MX tab to validate currently configured MX Records
  2. Navigate to the Dig Tool.
  3. Select NS.
  4. In the name field, type in your domain name and press Enter.
    •  for example: example.com
    • Do not enter www before your domain name.
    • If you receive the message Record not found! ensure that you spelled your domain correctly.
    • If you receive an output, proceed to the next step, otherwise, contact support for assistance.
  5. Select MX. An output of your MX Records will show. Your MX Records must look like the following (in any order):
    Exchange	          Preference
    aspx.l.google.com	        1
    alt1.aspmx.l.google.com     5
    alt2.aspmx.l.google.com	    5
    alt3.aspmx.l.google.com     10
    alt4.aspmx.l.google.com     10
    • TTL: (a value of time, this can be ignored)
    • EXCHANGE: (see below)
    • PREFERENCE: (see below)
  6. If you do not see this information returned, or other exchange listed with different preferences, update your domain's MX records to match these. For instructions on how to perform this action, please see the Activate Gmail for Workspace article for the common domain host or reach out to your domain host for more assistance.
  7. Please wait up to 72 Hours for these changes to propagate.

Cause

MX Records are required to be set or updated to the information shared above in order for your company's mail server to know where to deliver it's email messages.