Emails bounce when an external user send emails to a group

Problem

An external user sends emails to a group, but they get bounced with an error:
The account sender@domain.com is disabled.

Environment

  • Gmail
  • No changes reported recently to the group
  • Sender with a disabled account

Solution

  1. Sign in to your Google Account on a browser, like Chrome.
  2. If your account is disabled, you'll get an explanation.
  3. If you own the account, you can request access to it again.
    1. Sign in to your Google Account on a browser, like Chrome.
    2. Select Start Appeal.
    3. Follow the instructions.

Cause

  • Sender uses another email provider, and created a Google account.
  • Google account was disabled.
  • Expected behavior, when account is disabled, the emails sent to a group will be bounced.