Managed devices upgrade to Android Device Policy

Problem

Your work profile stopped syncing and you mat get one of the following error messages:
  • Users who have Work Profile suddenly stopped syncing
  • Work Profile cannot be added

Environment

  • Android devices running on Advanced MDM with a existing work profile.
  • Confirm the Device Policy app is in use. If the device uses Google Apps Device Policy, you must transition to the new Android Device Policy application. 

Solution

  1. Check the settings if the OU is still using the Advanced MDM.
  2. If  Google Apps Device Policy is in use, you must transition to the new Android Device Policy application. 
  3. To transition to the new Android Device Policy, remove the existing work Profile and delete the Google Apps Device Policy app.
  4. Follow the steps for Set up Google Workspace on an Android device
Note: If the device is added as company owned or user select Work Only when they set up their account before, Factory Reset is needed to resolve the issue

 

Cause

If you have a have existing Work Profile under the old Google Apps Device Policy application, it is no longer supported, you must transition to the new Android Device Policy app.