Problem
Your work profile stopped syncing and you mat get one of the following error messages:
- Users who have Work Profile suddenly stopped syncing
- Work Profile cannot be added
Environment
- Android devices running on Advanced MDM with a existing work profile.
- Confirm the Device Policy app is in use. If the device uses Google Apps Device Policy, you must transition to the new Android Device Policy application.
Solution
- Check the settings if the OU is still using the Advanced MDM.
- If Google Apps Device Policy is in use, you must transition to the new Android Device Policy application.
- To transition to the new Android Device Policy, remove the existing work Profile and delete the Google Apps Device Policy app.
- Follow the steps for Set up Google Workspace on an Android device
Cause
If you have a have existing Work Profile under the old Google Apps Device Policy application, it is no longer supported, you must transition to the new Android Device Policy app.