Message bounced due to organizational settings

Problem

When a split delivery rule is triggered to send messages to the external server added in the hots, it bounces back with the error:
Message bounced due to organizational settings.

Environment

  • Gmail
  • Admin console

Solution

  1. Log in to the Admin console.
  2. Hover your mouse on the left then click Apps Google Workspace Gmail.
  3. Click Hosts.
  4. Next to the host already added click Edit then uncheck the box Require mail to be transmitted via a secure (TLS) connection (Recommended).
  5. Click Save.
  6. Allow 24 hours propagation.

Cause

By checking a message ID in the Email Log Search it bounced back with the error TLS Negotiation failed, the certificate doesn't match the host. If the external server does not support TLS this box needs to be unchecked or confirm if they can support