Multiple device showing in Endpoint

Problem

Multiple devices are showing for a user when viewing Endpoint.

Environment

  • Endpoint
  • Device management
  • Admin console

Solution

  1. At the top of the device listing, click Add a filter.
  2. Select Management type.
  3. Choose the type you want to see.
    • (Optional) To see information about a specific device, click the device.

Cause

This could happen if the user is using another browser (Chromium based) on the device, for example Edge, Brave. On MacOS could also be caused by Chrome being unable to access the Endpoint Verification Safe Storage secret's Access Control page.