Problem
External non Google users are not able to upload files to a shared folder, even when it has been shared to them.
Environment
- Drive
- Web Client
Solution
Delete the visitor session:
- Sign in to your visitor session using the Invitation to [Edit/Comment/View] email from Google.
- In the top right, click your initial.
- Click Delete visitor session.
- Click Send.
- In your email inbox, open the verification code email.
- Enter the verification code in the box provided and click Next.
- Click the checkbox > Delete.
- Go to the Google Account sign in page.
- Click Create account.
- Enter your name.
- In the Username field, enter a username.
- Enter and confirm your password.
- Tip: When you enter your password on mobile, the first letter isn't case sensitive.
- Click Next.
- Optional: Add and verify a phone number for your account.
- Click Next.
Use an existing email address
- Go to the Google Account Sign In page.
- Click Create account.
- Enter your name.
- Click Use my current email address instead.
- Enter your current email address.
- Click Next.
- Verify your email address with the code sent to your existing email.
- Click Verify.
Cause
External users were trying to upload the files with a visitor session account, expected not to be able to upload files.