Problem
You notice that outbound messages are displaying a warning saying that they could possibly be spam (even though they are legit).
Environment
- Gmail delivery
Solution
If you have access to the domain host account and the respective DNS console, follow the steps described below:
- Access the domain host's account.
- Look for the DNS console or the section where DNS records are managed.
- Delete all SPF records but one and edit the remaining record's value in a way it includes all the servers needed (basically, merge all SPF records into one).
- Delete all duplicate DKIM records related to Google.
- Save the changes.
Cause
Multiple SPF and DKIM records were set up, which caused the messages to not be properly authenticated.