Outbound messages show an incorrect spam warning

Problem

You notice that outbound messages are displaying a warning saying that they could possibly be spam (even though they are legit).

Environment

  • Gmail delivery

Solution

If you have access to the domain host account and the respective DNS console, follow the steps described below:
  1. Access the domain host's account.
  2. Look for the DNS console or the section where DNS records are managed.
  3. Delete all SPF records but one and edit the remaining record's value in a way it includes all the servers needed (basically, merge all SPF records into one).
  4. Delete all duplicate DKIM records related to Google.
  5. Save the changes.
Note: Depending on the domain host it may take up to 72 hours for the changes to properly propagate.
 

Cause

Multiple SPF and DKIM records were set up, which caused the messages to not be properly authenticated.