送信メールに誤った迷惑メールの警告が表示される

問題

送信メールに(正当なメールであっても)迷惑メールの可能性があるという警告が表示されていることに気づきました。

環境

  • Gmail での配信

解決策

ドメインホスト アカウントとそれぞれの DNS コンソールにアクセスできる場合は、次の手順に沿って操作します。
  1. ドメインホストのアカウントにアクセスします。
  2. DNS コンソールまたは DNS レコードが管理されているセクションを探します。
  3. 1 つを除いてすべての SPF レコードを削除し、必要なすべてのサーバーが含まれるように残りのレコードの値を編集します(基本的に、すべての SPF レコードを 1 つに統合します)。
  4. Google に関連する重複する DKIM レコードをすべて削除します。
  5. 変更を保存します。
注: ドメインホストによっては、変更が反映されるまでに最長で 72 時間ほどかかることがあります。
 

原因

複数の SPF レコードと DKIM レコードが設定されているため、メールが適切に認証されませんでした。